CRAN Package Check Results for Package wallace

Last updated on 2021-09-23 02:49:31 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.1.0 3.27 33.46 36.73 OK
r-devel-linux-x86_64-debian-gcc 1.1.0 3.01 26.99 30.00 OK
r-devel-linux-x86_64-fedora-clang 1.1.0 54.67 NOTE
r-devel-linux-x86_64-fedora-gcc 1.1.0 45.78 NOTE
r-devel-windows-x86_64 1.1.0 7.00 44.00 51.00 OK
r-devel-windows-x86_64-gcc10-UCRT 1.1.0 ERROR
r-patched-linux-x86_64 1.1.0 3.97 33.22 37.19 OK
r-patched-solaris-x86 1.1.0 76.20 NOTE
r-release-linux-x86_64 1.1.0 3.63 33.67 37.30 OK
r-release-macos-arm64 1.1.0 NOTE
r-release-macos-x86_64 1.1.0 NOTE
r-release-windows-ix86+x86_64 1.1.0 13.00 41.00 54.00 OK
r-oldrel-macos-x86_64 1.1.0 NOTE
r-oldrel-windows-ix86+x86_64 1.1.0 8.00 43.00 51.00 OK

Check Details

Version: 1.1.0
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘DT’ ‘ENMeval’ ‘RColorBrewer’ ‘dismo’ ‘dplyr’ ‘jsonlite’
     ‘leaflet.extras’ ‘raster’ ‘rgdal’ ‘rgeos’ ‘rmarkdown’ ‘shinyjs’
     ‘shinythemes’ ‘sp’ ‘spThin’ ‘spocc’ ‘zip’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 1.1.0
Check: package dependencies
Result: ERROR
    Packages required but not available:
     'leaflet', 'ENMeval', 'leaflet.extras', 'rgdal', 'spocc'
    
    Packages suggested but not available for checking: 'rgbif', 'XML'
    
    See section 'The DESCRIPTION file' in the 'Writing R Extensions'
    manual.
Flavor: r-devel-windows-x86_64-gcc10-UCRT